OVH Community

Bienvenue sur votre espace communautaire. Posez des questions, recherchez des informations, publiez du contenu et interagissez avec d’autres membres OVH Community.

2 jours bientôt 3 sans base de données sql private !


#1

voila depuis bientot 3 jours que notre base de données sql private ne fonctionne plus. on paie une petite fortune cette db "pro" pour au final perdre plusieurs milliers de visiteurs et se dire qu on aurait mieux fait de rester sur une version mysql mutualise.

pire le help desk a ose nous demander si le probleme ne venait pas d un problème de programmation de notre côté.....

une panne je peux comprendre mais une absence de plan de secours NON

si dans quelques heures le service n est pas retabli, il faudra qu on songe a aller voir ailleurs.
notre site web est vital pour nous , on ne peut se permettre d attendre sans fin...

et si vous voulez voir le resultat de la panne ovh:

www.servicevolontaire.org


#2

Chez moi ça marche.

Par contre il y a la version avec et sans https accessible..

Autant forcer la version avec https.


#3

non il faut regarder le widget de droite, le moteur de recherche qui lui utilise la db sql private.

3 jours de panne !!!!
pour une version pro !!!!!

et j imagine vu qu on est le week end on est parti pour1 ou 2 jours supplémentaires.... ou plus....

inacceptable


#4

Bonsoir,

si je me rend sur votre site je vois sur le panneau de droite l'erreur : Warning: mysqli::__construct() expects parameter 5 to be integer, string given in /home/servicevlm/www/newsites/free/pierre/lib/util.php on line 67

C'est ici que se fait la connexion à mysql via la librairie mysqli
la fonction new mysql() prend 4 paramètres qui sont :
- l'hôte du serveur mysql
- le nom de la base de données
- l'identifiant de connexion
- le mot de passe

On peut ajouter le port en 5 ème paramètre.

Ici le message vous indique que ce 5 ème paramètres doit être un nombre et non une chaine de caractères.

Concrètement :
Dans votre fichier de config, vous devez avoir quelques choses dans le genre :

$dbhost ="sql.server.com";
$dbname ="base1";
$dbuser ="username";
$dbpass ="password";
$dbport = "3306";

il faudrait vérfiier que 3306 ne soit pas entre guillemets et qu'il soit plutôt comme ça :

$dbport = 3306;

Cordialement,
Boris.


#5

merci pour l'aide.
J'ai testé par acquis de conscience. Cela n'a rien changé....

Et en dehors du crash OVH rien n'a changé dans notre code source


#6

Pourtant l'erreur que vous avez est bien lié au code source.
Le problème des sql privés semble être résolu pour les autres utilisateurs.

Pouvez-vous copier ici les lignes correspondantes à la conf mysql (en masquant les infos sensibles)
Ainsi que les sources de la fonction __contruct pointé par l'erreur dans le fichier /home/servicevlm/www/newsites/free/pierre/lib/util.php ligne 79.

Cordialement,
Boris.