OVH Community

Bienvenue sur votre espace communautaire. Posez des questions, recherchez des informations, publiez du contenu et interagissez avec d’autres membres OVH Community.

Conseils pour étude d'offre PRO


#21

L'option du certificat SSL est déjà activé et en ligne : https://www.dday-overlord.com/

Est-ce qu'une option CDN pourrait accélérer les choses ?


#22

Oui.
Le cdn prendrait déjà en cache toutes les images et surtout le favicon problématique.

Pour le https,il faut aller dans le panneau admin de wordpress réglages et changer url du site et url de wordpress en remplaçant http:// par https://


#23

Le CDN a l'avantage que ton site peut profiter du http/2 . Par contre ce truc avec le favicon est un peu bizarre. As tu essayé juste pour voir désactiver ce favicon dans le thème ou plugin si ça accélère ton site ?


#24

J'ai désactivé le plugin du favicon, mis en place une option CDN et changé l'adresse en https, mais pas d'évolution de la rapidité du site, même en back-end.


#25

Le favicon il vaut mieux le faire 1 fois a la main et le poser sur le site.
Pas besoin de plug in pour un favicon.

Il faut attendre plusieurs heures pour que le site pointe vers l'ip du CDN.


#26

As tu vidé le cache produit par ton plugin ?
Toujours le même problème avec ce fameux favicon
https://tools.keycdn.com/speed?h=5b1121ad71bf2708ca243ab2


#27

Désormais, une fois le cache vidé, c'est encore pire.

Le délais d'attente est dépassé, les navigateurs ne peuvent pas attendre aussi longtemps, les pages ne s'affichent plus...

HELP !


#28

Et sinon complètement supprimé le favicon ?


#29

Chez moi ton site s'affiche rapidement
et même chez pingdom Load time : 3.19 s

et key CDN 3,5 sec
https://tools.keycdn.com/speed?h=5b1145b271bf2717231dcc32

Mais ton favicon et toujours là et le plus long. Par contre p.être grâce au http/2 ça ne semble plus bloquer


#30

Bonjour,

Avez vous suivi ce guide ? Notamment la partie qui vous explique les statistiques de l'hébergement ?

Vos requêtes sont très importantes, notamment sur une de vos bases qui en totalise 7 millions ces dernières 24h, c'est énorme. Cela vient forcément de quelque chose installé sur l'hébergement, il faut donc identifier ce qui crée tant de requêtes et faire en sorte qu'elles baissent.
Les logs pourront vous dire d'où viennent les requêtes (TCP out, web, erreurs...) Vocii un guide qui vous explique comment les lire :

@DominiqueT pour faire suite a votre message, @Gaston_Phone ne travaille effectivement pas chez nous, à notre grand regret. ;)

Cdlt,
ThT


#31

Par contre, il y a toujours un problème, le favicon n'existe pas, ce qui implique une redirection 301 inutile (qui fait perdre du temps ..)

il faudrait peut être mettre le favicon en dur dans à l'endroit suivant wp-content/uploads/2016/02/ puis suivre ce tutoriel https://wpformation.com/favicon-wordpress/

puisque le site est maintenant en HTTPS, autant ajouter ceci dans le fichier .htaccess

 #permet aux navigateurs de se souvenir qu'il doit passer en https pour votre site (HSTS)
Header set Strict-Transport-Security "max-age=16006000; includeSubDomains; preload"

#32

@Th.T concernant l'optimisation :
- activation de PHP-FPM : réalisé (en version 5.6).
- plugin de mise en cache : mis en place.
- CDN : commandé depuis hier.

Concernant les requêtes, elles vont augmenter ces prochains jours (il s'agit d'un site dédié à l'histoire du 6 Juin 1944, et la date anniversaire approche et nous sommes en pleine période de commémorations).
Je rencontre d'ailleurs actuellement des erreurs récurrentes "504 Gateway Timeout"... Le réseau fait des siennes pour changer.

@Buddy, j'ai mis à jour ce matin le fichier .htaccess.
Quant au Favicon, il n'apparait plus dans les requêtes, que ce soit sur Pingdom ou sur GTMetrix.

Ce qui est certain, c'est que la mise en place de l'option CDN n'a absolument RIEN changé à la vitesse du site. Soit c'est mal paramétré, soit c'est de la publicité mensongère...


#33

si si, il apparaît toujours ... (ligne 190 à 193 du code source de la page ...)

< link rel="icon" href="https://www.dday-overlord.com/wp-content/uploads/2016/02/favicon.ico.png" sizes="32x32" />
< link rel="icon" href="https://www.dday-overlord.com/wp-content/uploads/2016/02/favicon.ico.png" sizes="192x192" />
< link rel="apple-touch-icon-precomposed" href="https://www.dday-overlord.com/wp-content/uploads/2016/02/favicon.ico.png" />
< meta name="msapplication-TileImage" content="https://www.dday-overlord.com/wp-content/uploads/2016/02/favicon.ico.png" />

Donc pour accélérer le site, il faut qu'il y ait un fichier à cette URL
https://www.dday-overlord.com/wp-content/uploads/2016/02/favicon.ico.png

Le CDN permet de prendre en charge l'affichage des images et de les servir plus rapidement. Après c'est sur, ça ne fait pas gagner 90 % du temps ...
mais encore une fois, la majorité du temps perdu et dû au favicon ...

il est toujours présent sur le gtmetrix..
https://gtmetrix.com/reports/www.dday-overlord.com/9QAoo1fB on voit plusieurs favicon.ico.png dans le waterfall..


#34

Bonjour,

perso ce que je retient surtout de l'intervention de @Th.T c'est ceci :

Alors je sais pas vous avez quoi comme plugins ou combien, mais là clairement certains doivent abuser sur les requêtes et/ou votre plugin de cache est totalement inutile.

Cordialement, janus57


#35

Pour que le CDN fonctionne bien (protocole http/2) il faut que TOUS les sites soit en https (et les liens aussi).

quand on regarde le menu tous les liens sont encore en http:// au lieu de https://

<li id="menu-item-35905" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35905"><a href="http://www.dday-overlord.com/debarquement-normandie/">Jour-J</a></li>
<li id="menu-item-35906" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35906"><a href="http://www.dday-overlord.com/bataille-normandie/">Bataille de Normandie</a></li>
<li id="menu-item-35907" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35907"><a href="http://www.dday-overlord.com/normandie/">Normandie</a></li>
<li id="menu-item-35909" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35909"><a href="http://www.dday-overlord.com/mediatheque/">Médiathèque</a></li>
<li id="menu-item-35912" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35912"><a href="http://www.dday-overlord.com/materiel/">Armographie</a></li>
<li id="menu-item-35910" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35910"><a href="http://www.dday-overlord.com/filmographie">Filmographie</a></li>
<li id="menu-item-35911" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35911"><a href="http://www.dday-overlord.com/bibliographie">Bibliographie</a></li>
<li id="menu-item-38924" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38924"><a href="http://www.dday-overlord.com/boutique">Boutique</a></li>
<li id="menu-item-38923" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38923"><a href="http://www.dday-overlord.com/souvenir">Mémorial</a></li>
<li id="menu-item-39209" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39209"><a href="http://www.dday-overlord.com/forum/">Forum</a></li>

Idem pour le forum, il faut le passer en https.
forum phpbb => panneau administration => parametres du serveur => Paramètres des URLs du serveur =>
Protocole du serveur https://
Port du serveur : 443

si tout est en https, ça permet d'utiliser le protocole HTTP/2 qui permet de charger plusieurs fichiers sur une même requête et donc de gagner en rapidité de chargement. (le CDN utilise le HTTP/2 quand le site est en https car les navigateurs n'ont pas implémenté le http/2 sur le http. Google, mozilla en autre force le HTTPS pour la sécurisation des sites internet / vie privée ).


#36

Je dirait la piste des plugins ultra gourmand en requêtes vers la base de donnés est la bonne.
Perso j'avais fait l'expérience sur un site d'un client que certains plugins de sécurisation font énormément de requêtes à la BDD. C'est juste une piste
Le site est effectivement parfois en "time out"


#37

Tout d'abord, merci à tous les participants pour votre patience et vos conseils. Cela permet de lever quelques lièvres et ce n'est pas négligeable, même si je suis encore loin du but.

Les liens et le forum phpbb sont en cours de tous passer en https.
Le favicon supprimé du dossier a été remis à sa place.

Je dois faire face actuellement à un nombre impressionnant d'erreurs 504 Gateway Time-out... je ne peux même plus travailler sur le site, même en back-end...

Un ticket a été ouvert à destination d'OVH.


#38

Bonne nouvelle, cela va mieux...

Deux solutions : soit OVH s'est penché sur le sujet de son côté (peu probable), soit le plugin "Autoptimize" (compresse les CSS et JavaScript) que j'ai activé a amélioré les choses de lui-même (le plus probable).

Il reste encore une large voie d'amélioration, mais je peux désormais travailler en back-end.


#40

Bonjour,

il faut savoir que dans la majorité des cas le problème viens des plugins/thèmes.

Cordialement, janus57


#41

a moins que les css ou javascript soit très très mauvais (ce qui est très très très rare de nos jours surtout sur des sites avec wordpress, je pense que le problème est ailleurs ...
en prennant de la marge, la connexion moyenne des français est à 6 Mbits. gagné 0.05 Mo (ce qui est déjà énorme sur de tels fichiers) ne fait gagner que 0,07 à 0,1 sec ...

je pense que le problème est ailleurs ...
votre thème qui n'a pas l'air optimisé déjà et clairement pas à jour (sinon il serait compatible php 7.1 ou 7.2 )
php 7 apporte un gain de performance de 30 % voire plus par rapport à php 5.6 ...