OVH Community

Bienvenue sur votre espace communautaire. Posez des questions, recherchez des informations, publiez du contenu et interagissez avec d’autres membres OVH Community.

HTTP ERROR 500 que sur le site OVH


#1

Bonjour, je programme mon site WEB en PHP et j'ai une erreur sur mon site en ligne que je n'ai pas sur mon ordinateur en local, lorsque j'essaye de faire charger ce que j'appelle une infopage mon navigateur m'indique une erreur 500.

Le fonctionnement de mon système d'infopages:
- Le programme recherche le chemin d'accès vers l'infopage en question dans la base de donnée
- Le programme inclus le chemin d'accès trouvé sur la page demandée par l'utilisateur par le biais de la fonction require() de PHP

J'ai déjà essayé de modifier les chmod des fichiers mais cela ne change rien au problème !

Merci d'avance pour votre aide !


#2
  • Vérifier que les identifiants pour l'accès à la BD sont corrects (= phpmyadmin)
  • Tester avec une page index.html simple
  • Si fichier htaccess vérifier l'encodage (= ANSI)

#3

-> Vérifié

Fonctionne, les autres pages de mon site fonctionnent, je pense qu'il y a juste un problème avec le fonctionnement des infopages

J'ai déjà essayé de supprimer le fichier .htaccess mais l'erreur persiste donc le problème ne viens pas de ça

Merci tout de même de votre attention envers mon problème !


#4

Bonjour,

et vous avez regardé les logs tout simplement pour voir d'où viens l'erreur ?

Cordialement, janus57


#6

Bonjour, merci du conseil mais je ne me suis jamais vraiment aventuré dans les logs de mon site sur OVH ou devrais-je regarder dans les logs pour voir d'ou viens l'erreur ?


#7

Bonjour,

il suffit de regarder les logs au moment de l'erreur 500, normalement cela devrais donner plus de détails.

Après sans avoir de lien vers la page qui provoque l'erreur ou un bout des logs…

Cordialement, janus57


#8

Je suis un peux perdu^^


#9

Bonjour,

ça c'est les stats, pas les logs.

Cordialement, janus57


#10

Oui mais quand je clique sur les logs ça me met sur la page des stats ...


#11

Bonjour,

vous cliquer sur quel lien ?

Cordialement, janus57


#12

Hmmm


#13

Bonjour,

non je parle sur l'image précédente.

Cordialement, janus57


#14

Ce nest pas Avast qu'il faut regarder, mais Apache (web,error)


#15

Et ou puis-je trouver ça ? Je suis un peux perdu...


#16

Bonjour,

2 images plus haut vous l'avez il suffit juste de choisir le lien des logs et non awstats.

Cordialement, janus57


#17

C'est bon je crois que j'ai trouvé:


#18

Bonjour chers tous
j'ai mis mon site en ligne sur OVH il quelques temps et hier soir j'ai ajouté une base de données Mysql. Aujourd'hui j'ai l'erreur 500. svp aidez moi je n'ai aucune idée de la solution. Déjà je n'utilise pas de cms ni de plugins. juste un code en php html et javascript


#19

Bonjour,

Le plus simple est de faire votre propre topic avec un maximum de détails.

Cordialement, janus57


#20

Je penses que c'est le même problème que moi si il a déjà vérifié les permissions de ses fichiers et le fichier .htaccess