OVHcloud Community

Welcome to your community space. Ask questions, search for information, post content, and interact with other OVHcloud Community members.

Could not connect to remote process. Aborting debug session. Attach Debugger OK button is grayed out


#1

When I try to debug the app, the emulator sticks on “Waiting for debugger”. Meanwhile, in the debug tab, it can be seen that AS is “waiting for application to come online”. But after a moment shows “Could not connect to remote process. Aborting debug session”. As a further attempt, after running the app normally, I try to “Attach Debugger to Android Process”. “Choose Process” dialog is opened and the process on emulator is shown correctly, but the OK button is grayed out!

Android Studio version: 2020.3.1 patch 4: OS type and version: Windows 7 v6.1 Service Pack 1 Build: AI-203.7717.56.2031.7784292, 202110010236,

AI-203.7717.56.2031.7784292, JRE 11.0.10+0-b96-7249189x64 JetBrains s.r.o, OS Windows 7(amd64) v6.1 Service Pack 1, screens 1366.0x768.0

AS: Arctic Fox | 2020.3.1 Patch 3; Kotlin plugin: 203-1.6.0-release-798-AS7717.8; Android Gradle Plugin: 7.0.3; Gradle: 7.0.2; Gradle JDK: version 11.0.10; NDK: from local.properties: (not specified), latest from SDK: (not found); LLDB: pinned revision 3.1 not found, latest from SDK: (package not found); CMake: from local.properties: (not specified), latest from SDK: (not found), from PATH: (not found)Source: user_sentiment_feedback

I read and implemented all possible solutions in the web without any success. Still i encounter “Could not connect to remote process. Aborting debug session.” This happens on all apps with all emulator and real phones.