OVH Community

Welcome to your community space. Ask questions, search for information, post content, and interact with other OVH Community members.

IPv6 Configuration


#1

Someone asked me to make their vps accessible via ipv6. The address is 2607:5300:0201:3100:0000:0000:0000:1d64
I tried to tutorial in the docs but it just doesn’t work for me.
Can somebody help?
Ubuntu 16.04


#2

I’m using Debian which should be much the same. IPv4 is set up in /etc/network/interfaces.d/50-cloud-init.cfg but this doesn’t mention IPv6 for me either.

To resolve this I added the following (adjusted for your IP and what is likely to be the gateway - check in the VPS cloud control panel under Servers) in /etc/network/interfaces

iface ens3 inet6 static
        address 2607:5300:0201:3100::1d64
        netmask 64
        gateway 2607:5300:0201:3100::1
        dns-nameservers 2001:4860:4860::8888 2001:4860:4860::8844

Reboot and see if it worked! It is possible that you will also need (indented)

   up /sbin/ip -6 route add default via 2607:5300:0201:3100::1

But I didn’t need that for Debian.

This was also necessary for a Debain 9/stretch cloud instance. If it doesn’t work and the machine is no longer accessible you can mount /dev/vdb1 in rescue and remove it.

[In the cloud instance I used:

   dns-nameservers 2001:41d0:3:163::1

which was the output of

ping -6 cdns.ovh.net

However I did not do that for the VPS because they haven’t set that DNS server up locally in Australia (or haven’t given it multi-region DNS) and so it would end up going to a DNS server 200ms+ away. So check that the ping is less than the Google DNS addresses provided above before replacing it.]

FWIW: OVH really needs to figure out how to deploy IPv6 automatically, even if it’s just the default IPv6 and not a routed /64. It’s counterproductive to list listing public cloud IP addresses that won’t work out of the box because they may be enabled in DNS by the user and then cause issues.


#3

Agree. I am using the simplest VPS you can imagine with Debian Stretch. Enabling IPv6 “one shot” works fine.
I tried to make the configuration permanent by adding the interface in /etc/network/interfaces (following the guide https://docs.ovh.com/fr/public-cloud/configurer-ipv6/#via-votre-espace-client ) but that doesn’t seem to work. And all the configuration of iptables for IPv6 is not so evident neither.
It would be good if the tutorial for the VPS would include an uptodate section on how to enable IPv6 and the default image should enable it too (with closed firewall rules by default?)


#4

This solution worked for me - OVH VPS with Ubuntu 18.04:

sudo nano /etc/netplan/50-cloud-init.yaml

In the addresses: section, add each IPv6 address on its own line, as follows:

network:
version: 2
ethernets:
eth0:
addresses:
- 203.0.113.213/20
- your_primary_ipv6_address/64
- your_additional_ipv6_address/64
- 192.0.2.11/16
gateway4: 206.189.208.1
gateway6: ipv6_gateway
match:
macaddress: ce:2c:ex:am:pl:e6

To apply the change and test:

Run sudo netplan apply --debug. When the command is successful, it won’t provide output.
Run ping6 your_additional_ipv6_address. If you can reach the new address with ping6, it is correctly configured.

Source:


#5

I had troubles configuring then I read this. So, I took the info in that article and composed my own for ipv6 here. Anyway, now IPv6 is working consistently.


#6

This text will be hiddenTo get IPv6 to work I just add this file
/etc/network/interfaces.d/50-static-ipv6.cfg

With the contents

iface ens3 inet6 statics
(indent) address 2607:5300:201:3100::2774/64
(indent) gateway 2607:5300:0201:3100::0001


#7

iface ens3 inet6 statics
(indent) address 2607:5300:201:3100::2774/64
(indent) gateway 2607:5300:0201:3100::0001

what is?


#8

Hello guys, and what about CentOS?
Thanks