OVHcloud Community

Welcome to your community space. Ask questions, search for information, post content, and interact with other OVHcloud Community members.

IPv6 on dedicated server


#1

Hello,

After doing “ip address show” I get the following on the active network interface: eno0 (hiding IPs on purpose):

2: eno0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether *****************
inet ********** brd ********** scope global dynamic eno0
valid_lft 85117sec preferred_lft 85117sec
inet6 ********** scope link
valid_lft forever preferred_lft forever

How do I enable IPv6 on my server (keep in mind I will still want to be able to SSH to the server from my IPv4 address at home) ?
Thanks in advance.


#2

What I do is, first, set a live ipv6:

sudo ip -6 addr add 2001:****/128 dev ens3
sudo ip -6 route add 2001:****::1 dev ens3
sudo ip -6 route add default via 2001:****::1 dev ens3

If it works, then set it on the configuration. On Debian:

sudo vim /etc/network/interfaces.d/60-ipv6
iface ens3 inet6 static
	address 2001:****
	netmask 128
	scope global
	gateway 2001:****::1

#3

Yeah, ty for the reply. That’s what I ended up doing for IPv6 to be enabled.