OVH Community

Welcome to your community space. Ask questions, search for information, post content, and interact with other OVH Community members.

Request: mongodb extension and libs PHP 7.4 and new PHP 8


#1

I am quite disappointed. The installed version of the extension and the versions of libraries for mongodb in PHP from your webhosting are very deprecated. I have been asking about these server extensions on the official page and they have told me that version 1.5.0-dev in your hosting must have been created from a Beta bin, because that version is not recommended at all. It’s even better to downgrade to 1.4.X before using 1.5.X and even worse 1.5.0-dev.

It doesn’t matter which Driver you install in your uploaded app to handle the connection. On the official mongodb website they show a compatibility table. And the one installed on these servers is not appropriate. That is, the installed extension (1.5.0-dev) is not compatible with the installed libraries (libbson libmongoc 1.11.0-dev ) . And it does not matter which Driver you install in the web app because if it does not fail on the one hand, it fails on the other.

Now on November 26 they release PHP 8, and I wonder if: Could you please install chord extensions? I recommend:

MongoDB extension version 1.8.0
MongoDB extension stability stable
libbson bundled version 1.17.0
libmongoc bundled version 1.17.0

And if you fix it for 7.4 it would already be wonderful.

Thanks so Much