OVH Community

Welcome to your community space. Ask questions, search for information, post content, and interact with other OVH Community members.

Ubuntu 20.04 image in OVH has been marked as DEPECRATED


#1

During all this day I could not create ANY instance in ANY zone with Ubuntu 20.04.
After hours spent, 20 minutes ago I could do it but all the instances I had created with Ubuntu 20.04 has been REPLACED as “Ubuntu 20.04 - deprecated - 2020-12-03”.
I don’t have any official response after 5 tickets. I don’t know if all my instances created with Ubuntu 20.04 in the past will work properly or not, or if they need to be changed
Now Ubuntu 20.04 image can be install again in instances … it’s a new ubuntu 20.04 ?
The old one was corrupted?
Any news?

I’ll try to resume with facts:

  1. Today, I couldn’t create a simple instance B2-15 in GRA with Ubuntu 20.04 that I needed for deploy my project and move everything from AWS to OVH at last.
  2. After some tickets messages, a support guy told me there were not more B2-15 instances available in GRA
  3. I tried to create other type of instances (R2-15 and others), and in other places (SGR, WAW, LON1, FRA …) with no success. I created a ticket but no response, btw.
  4. I tried to create other bigger instances (R2-30 and bigger) but I had no quota, I tried to request more with the button, but it returned an error message. I created another ticket but no response, btw.
  5. After hours and hours trying , I decided to try with openstack … same results, I couldn’t create it … no combination, no type of instance. I created another ticket but no response, btw.
  6. Then I decided to change the linux image, and I tried with Debian … and voila! I could create it not only in another zone (first I tried with FRA), but in the original GRA where I couldn’t do it … where supposedly I couldn’t because there were not available resources.
  7. Then I tried to go to Horizon and change the image (reinstalling) to an Ubuntu 20.04 … and I could do that succesfully !!!

But here comes the real weird thing happened close to mignight (about 20 minutes ago):

  • Now I have a recently created instance in Debian turned into a Ubuntu 20.04 (in my instances table it’s labelled with “Ubuntu 20.04”… but
  • Now, all the instances I had (created in the last days) with Ubuntu 20.04 has NO LABEL in the main table, but in the details, now it says “Ubuntu 20.04 - deprecated - 2020-12-03”

Table right now:

In that table, before midnight, that’s to say … “yesterday until about 23:55” I could see “Ubuntu 20.04” in the “Imagen” column of the first 3 instances … but now they disappeared !! and in the details page of each one I can see this:

My thoughts of what happened:

It was NOT a problem of availability in GRA zone, but a problem creating ANY instance in ANY place with the Ubuntu 20.04. Maybe it was a corrupt image and you noticed that, and you changed all the “labels” in the instance details page to “Ubuntu 20.04 - deprecated - 2020-12-03” … This happens at midnight (about 20 minutes ago).

Problems that I see here:

  • Bad communication of support team, that gave me a wrong definition of the problem
  • Bad communication of error messages in your panel because it seemed a problem with the “type of instance” or “zone”, not a problem with the linux image
  • Hours spent here :frowning:

I hope this will help you … I’m very frustrated, unhappy and tired of today …

Good night


#2

Hi Alex, have you received any feedback from OVH support? I’ve just noticed that name of OS distribution in one of my instances has been renamed to “Ubuntu 20.04 - deprecated - 2020-12-03”.

Hae you learned anything about this case?

Thanks.


#3

Yes.
They upgraded ubuntu version last friday.
During all that day it was impossible to create Ubuntu instances but they didn’t admit it
They just admitted they usually changed the distro, and when this happened, they label the old ones as “deprecated”, although you can use them yet.


#4

Hi @AlexD2

OVH’s public and private Cloud department usually resolves incidents quite quickly at the platform level since they are focusing on that, hopefully they can resolve the situation as soon as possible. Thank you for sharing your experience, you keep us informed of anything

Regards,


#5

Hello,

When you see the image as “DEPECRATED” what it means it is no longer made available for the customer to use for instance creation or reinstall. The public cloud team provides regularly new images with the latest updates at the time of the image creation. Therefore, when you create an instance or reinstall, you would have a reasonably up-to-date operating system already. Simply put an image marked as “DEPECRATED” means its no longer available for customers. Your server can still run on it, but if you reinstall it will not be with the same image, but the current image that is available.

The public cloud team posts these here: http://travaux.ovh.net/?project=17&status=all&perpage=50

There is also a change log publish usually shortly after the images are updated: https://docs.ovh.com/gb/en/public-cloud/pci-vps-image-changelog/

Usually the change log is just adding the new images with the latest updates at the time. If there is something extra, it would also get mentioned.

Hope this answers your question regarding why images get marked “DEPECRATED”.